Skip to content

Most visited

Recently visited

navigation

Developer Kits

Discover the hardware platforms supported by Android Things as well as developer kits to help you quickly get started with the code samples and tutorials. Learn more about each platform below and choose the one that best fits your app.



Hardware platforms

Platform NXP Pico i.MX7D

Learn More
Where to buy
Get Started - i.MX7D
Get Started - Pico Pro Maker Kit
NXP Pico i.MX6UL

Learn More
Where to buy
Get Started
NXP Argon i.MX6UL

Learn More
Where to buy
Get Started
Raspberry Pi 3

Learn More
Where to buy
Get Started
Get Started - Raspberry Pi 3 Starter Kit
CPU & Memory
  • NXP i.MX7D
  • 1GHz dual-core ARM Cortex A7
  • 512MB RAM
  • NXP i.MX6Ultralite
  • 500MHz ARM Cortex A7
  • 512MB RAM
  • NXP i.MX6Ultralite
  • 500MHz ARM Cortex A7
  • 512MB RAM
  • Broadcom BCM2837
  • 1.2GHz quad-core ARM Cortex A53
  • 1GB RAM
GPU N/A N/A N/A VideoCore IV
Storage 4GB eMMC 4GB eMMC 4GB eMMC MicroSD card slot
Display DSI No No HDMI + DSI
Camera CSI-2 No No CSI-2
Audio 3.5mm Analog 3.5mm Analog 3.5mm Analog USB 2.0
3.5mm Analog Output
Networking 10/100/1000 Ethernet
Wi-Fi 802.11ac (2.4/5.0GHz)
Bluetooth® 4.1
10/100 Ethernet
Wi-Fi 802.11n (2.4GHz)
Bluetooth® 4.1
10/100 Ethernet
Wi-Fi 802.11n (2.4GHz)
Bluetooth® 4.1
10/100 Ethernet
Wi-Fi 802.11n (2.4GHz)
Bluetooth® 4.1
USB 1x USB 2.0 Host
1x USB 2.0 OTG
1x USB 2.0 Host
1x USB 2.0 OTG
1x USB 2.0 Host
1x USB 2.0 OTG
4x USB 2.0 Host

The following developer kits are designed to work with the Android Things code samples.

Adafruit Project Kit

For all supported boards

The project kit provides a flexible way of getting started on all supported boards.

Pimoroni Rainbow HAT

For Raspberry Pi

The Rainbow HAT offers a plug and play solution for getting started on Raspberry Pi.

This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience. (Dec 2017 Android Platform & Tools Survey)