Thêm tính năng hỗ trợ cho Android Auto vào ứng dụng đa phương tiện

Bạn cần thực hiện một vài thay đổi đối với tệp kê khai của ứng dụng để Android Auto có thể khám phá và tương tác với dịch vụ trình duyệt nội dung phương tiện của ứng dụng.

Đặt minSdkVersion của ứng dụng

Android Auto yêu cầu ứng dụng nhắm mục tiêu đến Android 6.0 (API cấp 23) trở lên.

Để chỉ định giá trị này trong dự án, hãy đặt thuộc tính minSdkVersion trong phần tử uses-sdk thành 23 trở lên trong tệp AndroidManifest.xml của mô-đun ứng dụng dành cho điện thoại, như trong ví dụ sau:

<manifest xmlns:android="http://schemas.android.com/apk/res/android" ... >
    <uses-sdk android:minSdkVersion="23" android:targetSdkVersion="32" />
    ...
</manifest>

Khai báo dịch vụ hỗ trợ nội dung phương tiện cho Android Auto

Sử dụng mục nhập tệp kê khai sau đây để khai báo rằng ứng dụng dành cho điện thoại của bạn hỗ trợ Android Auto:

<application>
    ...
    <meta-data android:name="com.google.android.gms.car.application"
        android:resource="@xml/automotive_app_desc"/>
    ...
</application>

Mục nhập tệp kê khai này là một tệp XML khai báo những chức năng của ô tô mà ứng dụng hỗ trợ. Để biểu thị bạn có một ứng dụng đa phương tiện, hãy thêm tệp XML có tên automotive_app_desc.xml vào thư mục res/xml/ trong dự án. Tệp này phải bao gồm nội dung sau:

<automotiveApp>
    <uses name="media"/>
</automotiveApp>

Báo cáo sự cố về nội dung phương tiện trên Android Auto

Nếu gặp sự cố trong khi phát triển ứng dụng đa phương tiện cho Android Auto, bạn có thể báo cáo bằng Công cụ theo dõi lỗi của Google. Hãy nhớ điền tất cả thông tin được yêu cầu vào mẫu báo cáo lỗi.

Tạo lỗi mới

Trước khi báo lỗi mới, vui lòng kiểm tra xem lỗi đó đã được báo cáo trong danh sách lỗi hay chưa. Bạn có thể đăng ký theo dõi và bỏ phiếu cho các lỗi bằng cách nhấp vào dấu sao cho một lỗi trong công cụ theo dõi. Để biết thêm thông tin, hãy xem bài viết Đăng ký theo dõi lỗi.