Menambahkan dukungan untuk Android Auto ke aplikasi media Anda

Anda perlu membuat beberapa perubahan pada manifes aplikasi agar Android Auto dapat menemukan dan berinteraksi dengan layanan browser media di aplikasi Anda.

Menetapkan minSdkVersion aplikasi Anda

Android Auto mengharuskan aplikasi Anda menargetkan Android 6.0 (API level 23) atau yang lebih tinggi.

Untuk menentukan nilai ini dalam project Anda, setel atribut minSdkVersion di elemen uses-sdk ke 23 atau yang lebih tinggi dalam file AndroidManifest.xml modul aplikasi telepon Anda, seperti ditunjukkan dalam contoh berikut:

<manifest xmlns:android="http://schemas.android.com/apk/res/android" ... >
    <uses-sdk android:minSdkVersion="23" android:targetSdkVersion="30" />
    ...
</manifest>

Mendeklarasikan dukungan media untuk Android Auto

Gunakan entri manifes berikut untuk mendeklarasikan bahwa aplikasi telepon Anda mendukung Android Auto:

<application>
    ...
    <meta-data android:name="com.google.android.gms.car.application"
        android:resource="@xml/automotive_app_desc"/>
    ...
</application>

Entri manifes ini merujuk ke sebuah file XML yang mendeklarasikan kapabilitas otomotif yang didukung aplikasi Anda. Untuk menunjukkan bahwa Anda memiliki aplikasi media, tambahkan file XML dengan nama automotive_app_desc.xml ke direktori res/xml/ di project Anda. File ini harus mencakup konten berikut:

<automotiveApp>
    <uses name="media"/>
</automotiveApp>

Melaporkan masalah Media Android Auto

Jika mengalami masalah dengan pengembangan aplikasi media untuk Android Auto, Anda dapat melaporkannya menggunakan Issue Tracker Google. Pastikan untuk mengisi semua informasi yang diminta pada template masalah.

Laporkan masalah baru

Sebelum mengajukan masalah baru, periksa apakah masalah tersebut sudah dilaporkan dalam daftar masalah. Anda bisa berlangganan dan memberi suara pada masalah dengan mengklik bintang untuk masalah di tracker. Untuk mengetahui informasi selengkapnya, lihat Berlangganan pada topik Masalah.