6월 3일의 ⁠#Android11: 베타 버전 출시 행사에 참여하세요.

예정된 Android 및 Google Play 기한

Google 플랫폼과 정책은 사용자 환경을 개선하고 더 안전한 생태계를 만들기 위해 끊임없이 발전하고 있습니다. 이 페이지를 참조하여 필수 변경사항에 관한 최신 소식과 추가 정보를 확인하세요. 앱과 게임을 지속적으로 업데이트해 주셔서 감사합니다.

타임라인

policy timeline policy timeline

추천 변경사항

Play 설치 리퍼러 API로 전환

설치 리퍼러 인텐트 브로드캐스트를 사용하여 앱 설치를 추적하는 개발자는 2020년 3월 1일까지 Play Install Referrer API로 전환해야 합니다. 대부분의 경우 인텐트는 분석을 제공하고 마케팅 캠페인 실적을 추적하는 타사 SDK(예: AppsFlyer 및 Kochava)에서 사용됩니다. 이때 개발자는 어떤 조치도 취할 필요가 없습니다. 파트너가 새로운 Play Install Referrer API를 이미 지원하기 때문입니다.

WorkManager로 백그라운드 작업 이동

2020년 4월 FirebaseJobDispatcher 라이브러리가 보관처리되며 Google에서는 더 이상 라이브러리에 관해 제출된 문제를 지원하지 않습니다. GCMNetworkManager 라이브러리에는 더 이상 새로운 기능이 추가되지 않으며 2020년 11월부터 Google에서는 라이브러리 관련 문제를 지원하지 않습니다. 앱에서 타겟 API 수준(targetSdkVersion)을 Android 10(API 수준 29) 이상으로 업데이트하면 FirebaseJobDispatcher 및 GcmNetworkManager API 호출이 Android Marshmallow 6.0 이상을 실행하는 기기에서 더 이상 작동하지 않습니다.

64비트 지원 필요

2019년 8월 1일부터 Google Play에 게시된 앱과 게임에서는 상응하는 32비트 아키텍처에 64비트 ABI를 지원해야 합니다. Corona Labs SDK나 Adobe Air 소프트웨어 및 Air SDK를 사용하는 앱과 게임은 2020년 8월 1일까지 유지됩니다. Unity 5.6.7 이하 버전으로 빌드된 게임은 2021년 8월 1일까지 유지됩니다.

앱은 API 수준 29를 타겟팅해야 함

APK를 업로드하는 경우 Google Play의 타겟 API 수준 요구사항을 충족해야 합니다. 새로운 앱은 2020년 8월 3일까지 Android 10(API 수준 29) 이상을 타겟팅해야 하며 업데이트되는 모든 앱은 2020년 11월 2일까지 Android 10(API 수준 29) 이상을 타겟팅해야 합니다. 이 날짜 이전의 새로운 앱 및 앱 업데이트는 Android 9(API 수준 28) 이상을 타겟팅해야 합니다.

Google Play 결제 라이브러리 2.0으로 이동

2021년 5월 1일부터 Play 결제를 사용하는 모든 새로운 앱과 앱 업데이트에는 Google Play 결제 라이브러리 2.0이 필요합니다.

Android 10 지원

강력한 사용자 개인정보 보호, 사용자와 소통하는 새로운 방법, 확장된 폴더블 지원 기능, Vulkan 확장 프로그램 등 Android 10의 새로운 기능을 위해 앱을 업데이트하세요.

지난 기한

스토어 등록정보 동영상에서 수익 창출 기능 사용 중지

2019년 11월 1일부터 Play 스토어에 동영상이 표시되는 방식이 일부 변경되었습니다. 이번 업데이트의 일환으로 수익을 창출하는 등록정보의 모든 YouTube 동영상에 광고가 게재될 수 있으므로 사용자에게 혼란을 주거나 방해가 될 수 있습니다. 이 날짜까지 광고를 사용 중지하지 않으면 동영상이 더 이상 Google Play에 표시되지 않습니다.

11월 Play 정책 업데이트 준수

2019년 11월 13일 Google에서는 왜곡된 주장, 메타데이터, 스팸 및 광고 네트워크 인증을 비롯하여 여러 주제에 관한 정책을 업데이트했습니다. 이제 게시하는 모든 앱에서 정책을 준수해야 합니다.

Google Play Developer API v3로 이동

2019년 12월 1일부터 인앱 구매와 게시 관리에 사용되는 Google Play Developer API의 버전 1과 버전 2를 더 이상 사용할 수 없습니다. 아직 업데이트하지 않은 경우 버전 3으로 업데이트하세요.