O Google tem o compromisso de promover a igualdade racial para as comunidades negras. Saiba como.

Adicionar compatibilidade com o Android Auto ao seu app de música

Você precisa fazer algumas alterações no manifesto do app para que o Android Auto possa descobrir o serviço de navegação de mídia do app e interagir com ele.

Definir a targetSdkVersion do seu app

O Android Auto exige que seu app segmente o Android 5.0 (API de nível 21) ou versões mais recentes.

Para especificar esse valor no projeto, defina o atributo targetSdkVersion no elemento uses-sdk como 21 ou versões mais recentes no arquivo AndroidManifest.xml do módulo do seu app para telefones, como mostrado no exemplo a seguir.

    <manifest xmlns:android="http://schemas.android.com/apk/res/android" ... >
        <uses-sdk android:minSdkVersion="4" android:targetSdkVersion="21" />
        ...
    </manifest>
    

Declarar compatibilidade de mídia com o Android Auto

Use a seguinte entrada de manifesto para declarar que seu app para smartphones é compatível com o Android Auto:

<application>
        ...
        <meta-data android:name="com.google.android.gms.car.application"
            android:resource="@xml/automotive_app_desc"/>
        ...
    <application>
    

Essa entrada de manifesto se refere a um arquivo XML que declara com quais recursos automotivos seu app é compatível. Para indicar que você tem um app de música, adicione um arquivo XML chamado automotive_app_desc.xml ao diretório res/xml/ no projeto. Esse arquivo precisa incluir o seguinte conteúdo:

<automotiveApp>
        <uses name="media"/>
    </automotiveApp>