提醒:从 2022 年 8 月 2 日起,所有新应用都必须使用结算库版本 4 或更高版本。自 2022 年 11 月 1 日起,现有应用的所有新版本都必须使用结算库版本 4 或更高版本。了解详情

Google Play 结算库版本废弃

正如 2019 年 Google I/O 大会和 Google Play 结算库版本 3 博文所宣布的,所有版本的 Play 结算库都将遵循两年的废弃周期。

本主题回答了关于结算库版本废弃和迁移到更高版本的常见问题。

如何知道哪个 APK 或 App Bundle 触发了弃用警告?
查看您项目中已导入的依赖项(例如,在项目的 build.gradle 文件中找到的依赖项)。为了符合要求,应用必须导入 4.0.0 或更高版本的 Play 结算库。请注意,您只会在需要 com.android.vending.BILLING 权限的 APK 中找到结算依赖项。
我不再维护的 APK 或 App Bundle 使用了已弃用的 Play 结算库版本。我需要更新吗?
我们强烈建议将所有 APK 的 Play 结算库更新到最新版本。不过,对于不再维护的 APK,您目前无需对其采取任何行动。此弃用机制仅会阻止新应用和应用更新使用旧版 Play 结算库。使用已弃用的结算库版本的现有应用将继续发挥预期功用。请务必更新所有在维护中的 APK。
如何解决 APK 或 app bundle 在更新至最新 Play 结算库后仍然会触发废弃警告的问题?
请确保您的 AndroidManifest.xml 包含名为 com.google.android.play.billingclient.version 的条目。如果该条目不存在,请检查您的清单合并设置,确认清单属性是否在清单合并期间被丢弃。
如何从较早版本的 Play 结算库进行升级?

将您版本中的依赖项更新为使用 v4 或更高版本的 Play 结算库。如需了解各版本之间有哪些变化,请参阅版本说明

此外,我们还提供了关于如何从 PBL 4 迁移到 PBL 5 的深度指南。