Kotlin Uyumluluk Haritası ile Oluştur

Bağımlılıkları bildirme

Compose Derleyici'ye bağımlılık eklemek için projenize Google Maven deposunu eklemeniz gerekir. Daha fazla bilgi için Google'ın Maven deposunu okuyun.

Uygulamanızın veya modülünüz için build.gradle dosyasına ihtiyaç duyduğunuz yapıların bağımlılıklarını ekleyin:

Modern

android {
    buildFeatures {
        compose true
    }

    composeOptions {
        kotlinCompilerExtensionVersion = "1.5.9"
    }

    kotlinOptions {
        jvmTarget = "19"
    }
}

Kotlin

android {
    buildFeatures {
        compose = true
    }

    composeOptions {
        kotlinCompilerExtensionVersion = "1.5.9"
    }

    kotlinOptions {
        jvmTarget = "19"
    }
}

Yayın Öncesi Kotlin Uyumluluğu

Kotlin'in yayın öncesi sürümleriyle uyumlu Compose Derleyici sürümleri için daha ayrıntılı bilgi için lütfen https://androidx.dev/storage/compose-derr/repository adresine göz atın.

Derleyici Sürümü Oluştur Uyumlu Kotlin Sürümü
1,5,9 1,9,22
1,5,8 1,9,22
1,5,7 9.1.21
1,5,6 9.1.21
1,5,5 1.9.20
1,5,4 1.9.20
1,5,3 1,9,10
1,5,2 1,9,0
1,5,1 1,9,0
1,5,0 1,9,0
1,4,8 1.8.22
1,4,7 8.1.21
1,4,6 1.8.20
1,4,5 1.8.20
1.4.4 1.8.10
1.4.3 1.8.10
1.4.2 1.8.10
1.4.1 1,8,0
1.4.0 1,8,0
1.4.0-alfa02 1.7.21
1.4.0-alfa01 1.7.20
1.3.2 1.7.20
1.3.1 1.7.10
1.3.0 1.7.10
1.3.0-rc02 1.7.10
1.3.0-rc01 1.7.10
1.3.0-beta01 1.7.10
1.2.0 1,7,0
1.2.0-rc02 6.1.21
1.2.0-rc01 6.1.21
1.2.0-beta03 6.1.21
1.2.0-beta02 6.1.21
1.2.0-beta01 6.1.21
1.2.0-alfa08 1.6.20
1.2.0-alfa07 1.6.10
1.2.0-alfa06 1.6.10
1.2.0-alfa05 1.6.10
1.2.0-alfa04 1.6.10
1.2.0-alfa03 1.6.10
1.2.0-alfa02 1.6.10
1.2.0-alpha01 1.6.10
1.1.1 1.6.10
1.1.0 1.6.10
1.1.0-rc03 1.6.10
1.1.0-rc02 1.6.10
1.1.0-rc01 1.6.0
1.1.0-beta04 1.6.0
1.1.0-beta03 1:5,31
1.1.0-beta02 1:5,31
1.1.0-beta01 1:5,31
1.1.0-alfa06 1:5,31
1.1.0-alfa05 1:5,31
1.0.5 1:5,31
1.0.4 1:5,31
1.1.0-alfa04 1,5,30
1.1.0-alfa03 1,5,30
1.0.3 1,5,30
1.1.0-alfa02 1.5.21
1.1.0-alpha01 1.5.21
1.0.2 1.5.21
1.0.1 1.5.21
1.0.0 1,5,10
1.0.0-rc02 1,5,10
1.0.0-rc01 1,5,10