Configurar o NDK para o Plug-in do Android para Gradle

Esta página mostra como configurar o NDK no seu projeto de acordo com a versão do Plug-in do Android para Gradle (AGP, na sigla em inglês) usado pelo projeto.

As etapas variam de acordo com a versão do AGP usada no projeto. Localize a versão do Plug-in do Android para Gradle em um destes locais:

  • Menu File > Project Structure > Project no Android Studio
  • Arquivo build.gradle de nível superior do projeto

Selecione a versão abaixo:

AGP versão 4.1+

As opções para configurar o NDK são as seguintes:

  • (Recomendado) Usar a propriedade ndkVersion para definir a versão do NDK.
  • Não definir nenhuma propriedade. O Android Studio fará o download automático da versão padrão do NDK para a versão específica do AGP (neste caso, a versão 21.0.6113669) ou você poderá instalar o NDK pela linha de comando. O Android Studio instala todas as versões do NDK no diretório android-sdk/ndk/. Cada versão está localizada em um subdiretório com o número da versão como o nome.
  • Para casos de uso especiais, use a propriedade ndkPath:

    android {
      ndkPath "/Users/ndkPath/ndk21"  // Point to your own NDK
    }
    

Instalar o NDK na linha de comando

Para instalar o NDK pela linha de comando, faça o seguinte:

  1. Use a ferramenta sdkmanager para ver as versões dos pacotes disponíveis do CMake e do NDK. Assim como outros componentes do SDK, o NDK é lançado em canais diferentes:

    sdkmanager --list [--channel=channel_id]  // NDK channels: 0 (stable),
                                                // 1 (beta), or 3 (canary)
    
  2. Passe as strings ao sdkmanager pelos pacotes que você quer instalar. Por exemplo, para instalar o CMake ou o NDK, use a seguinte sintaxe:

    sdkmanager --install
              ["ndk;major.minor.build[suffix]" | "cmake;major.minor.micro.build"]
              [--channel=channel_id]
    

    Use a opção --channel para instalar um pacote somente se ele tiver sido lançado em um canal até channel_id.

Para ver mais informações, consulte sdkmanager.